The Windows maze… where do I begin?

Media_httpgagravaarwo_tmhel

I’ve long thought that the complexities of the Windows world were, in part, exaggerated by Apple users and their media (I’ve even been guilty of it myself), but I’m here to tell you now, it’s worse than everyone’s ever thought. I’m now in charge of the company’s website. I relaunched it in the middle of last year and when faced with the complete rewrite that was needed, I decided that the best approach was a Content Management System (CMS) for the website so that anyone with a basic grasp of computers could update it. I certainly don’t have time to administer the website using Dreamweaver, so the plan was to buy in a CMS so that the less web-ware members of my staff could update the site in my absence. The journey through this has been a difficult one with various problems too numerous to mention, except one. One that has shown me that the complexities of the Windows world are not exaggerated. At the heart of the website is a registration system that allows a web-user to fill in a standard html form, upload a couple of graphics and then submit this to a choice of a dozen or so destinations. In the background this submission is then uploaded to a centrally stored database, and then automatically emailed to 1 of 10 users of the system. Once received, these users then contact the web-user and process their registration. Except it doesn’t work. In fact in the 10 months or so since the website launched, it’s never worked.Of course, actually finding this out was an arduous task in itself. Suffice to say after tracking the problem it appears it boils down to this: The web-users form is received centrally, perfectly. It’s when this form is emailed through my company’s webserver, we have a problem. It just never gets there. Doesn’t even register as spam, it just doesn’t arrive. Changing the destination to a ‘@googlemail.com’ domain – it works fine.It’s something to do with the website’s backend software communicating to our email server, they just don’t get along. Of course the one set of Windows users (who run the back-end website software for us), blame the other set of Windows users (who run our email server). I have the envious task of arranging a meeting between these 2 groups to hammer out a solution. In the meantime, I, a lowly Mac-user, not versed in the intricate voodoo of email systems, has come up with a solution. All submissions from the website go to a ‘@googlemail.com’ email address, I set up for this purpose. They then come through to Apple Mail, where a Apple Mail set of rules, then examines the email, determines which destination it’s meant for and then forwards it on. This works fine. But why doesn’t it one Windows based email system, work with another? It seems to me that these ‘experts’ haven’t a clue, at a low-level, how Windows actually works, and that is a scary thought, and it has taken a single G5 Mac and Apple Mail, to sort out the problem (at least in the short term).

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s